29 mar. 2013

Reparando wpscan

Bueno aqui otro error que me topé en Kali ahora con la herramienta wpscan:
____________________________________________________
 __          _______   _____                  
 \ \        / /  __ \ / ____|                 
  \ \  /\  / /| |__) | (___   ___  __ _ _ __  
   \ \/  \/ / |  ___/ \___ \ / __|/ _` | '_ \ 
    \  /\  /  | |     ____) | (__| (_| | | | |
     \/  \/   |_|    |_____/ \___|\__,_|_| |_| v2.0rNA

    WordPress Security Scanner by the WPScan Team
 Sponsored by the RandomStorm Open Source Initiative
_____________________________________________________

[ERROR] bad URI(absolute but no path): http://
Trace :
/usr/lib/ruby/1.9.1/uri/common.rb:146:in `split'
/usr/lib/ruby/1.9.1/uri/common.rb:211:in `parse'
/usr/lib/ruby/1.9.1/uri/common.rb:747:in `parse'
/usr/share/wpscan/lib/wpscan/wp_target.rb:37:in `initialize'
/usr/bin/wpscan:51:in `new'
/usr/bin/wpscan:51:in `
'

Bueno este error se resuelve instalando algunas dependencias faltantes con el siguiente comando:

aptitude install libcurl4-gnutls-dev libopenssl-ruby libxml2 libxml2-dev libxslt1-dev ruby-dev 

Este error me aparecio usando Kali Linux 1.0.1 x64 en VirtualBox, hay que recordar que es importante mantener actualizado nuestro sistema con:
aptitude update 
aptitude upgrade